Command & Conquer Communications Center

keeping the classics alive!

Author Topic: unable to find a version of the runtime to run this application  (Read 50189 times)

Offline helli

  • Minigunner/Rifle Soldier
  • *****
  • Posts: 5
    • View Profile
Hi  :)

today I installed CnCnet for the first time. (I installed Net Framework 4, too)

I got this error message:



Can somebody help me please ?

Offline Tore

  • Webmaster
  • Administrator
  • *
  • Posts: 1357
  • Dancing Tanks!
    • View Profile
    • http://www.cnc-comm.com
Re: unable to find a version of the runtime to run this application
« Reply #1 on: May 05, 2010, 06:19:13 PM »
Have you tried reinstalling .NET framework?

Offline helli

  • Minigunner/Rifle Soldier
  • *****
  • Posts: 5
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #2 on: May 05, 2010, 06:41:08 PM »
thx for your quick answer  :)

yes I tried but the result is the same  :huh:

when the installation is done I get a message that I should look for Windows Updates.

Can I ignore it ?

--> now I updated Windows but when I want to start cncnet.exe I get the same error message ..... help ^^
« Last Edit: May 05, 2010, 07:44:53 PM by helli »

Offline Irony

  • (Kind of AFK)
  • Global Moderator
  • *
  • Posts: 250
  • A little bit AFK atm
    • View Profile
    • 9point6
Re: unable to find a version of the runtime to run this application
« Reply #3 on: May 05, 2010, 07:48:07 PM »
Have you got .NET v2 and .NET v3 installed?

When you install .NET it doesn't include the previous versions.

Offline pichorra

  • Medium Tank
  • *
  • Posts: 771
  • A festive virus!
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #4 on: May 05, 2010, 08:24:39 PM »
.NET framework 4 only includes the .NET Framework 4, download and install the .Net Framework 2.
DOS Interface Mod for Command & Conquer 95
gibe moni plox I report u huehuehue brbr?

Offline Ferret

  • Medium Tank
  • *
  • Posts: 752
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #5 on: May 05, 2010, 09:22:32 PM »
Try to install .NET Framework 2.

Offline helli

  • Minigunner/Rifle Soldier
  • *****
  • Posts: 5
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #6 on: May 05, 2010, 10:26:36 PM »
I installed .Net Framework 2 and then .Net Framework 3.5 SP1

When I try to open CnCNet I get another error message:

Net/Server error, unable to update



what can I do now ?

Offline pichorra

  • Medium Tank
  • *
  • Posts: 771
  • A festive virus!
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #7 on: May 05, 2010, 10:39:32 PM »
did you allow the program on Windows Firewall? If you uses a personal firewall disable it.
DOS Interface Mod for Command & Conquer 95
gibe moni plox I report u huehuehue brbr?

Offline Ferret

  • Medium Tank
  • *
  • Posts: 752
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #8 on: May 05, 2010, 10:39:57 PM »
That means that you're not connected to the internet, or that your firewall is blocking the CnCNet executable.

Offline helli

  • Minigunner/Rifle Soldier
  • *****
  • Posts: 5
    • View Profile
Re: unable to find a version of the runtime to run this application
« Reply #9 on: May 05, 2010, 10:49:25 PM »
I found the problem ^^

I have to create an "administrator" account on xp.